Back to overview
CPU functions and GPU functions from Modal provider are down
May 19, 2026 at 1:36pm UTC
Affected services
Health
API Infrastructure
Resolved
May 19, 2026 at 1:36pm UTC
All services are back
Affected services
Resolved
May 19, 2026 at 1:36pm UTC
All services are back
Affected services